User Tag List

Results 1 to 3 of 3

Thread: How to setup RSLinx and download to a PLC-5 via Serial

  1. #1
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,341
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    6
    Thanked in
    6 Posts

    How to setup RSLinx and download to a PLC-5 via Serial


    So you need to know how to setup RSLinx Classic to communicate over serial with an Allen-Bradley PLC-5 so you can download or go online with RSLogix?
    Well you're in luck as in today's article I'll walk you step to setup through how to setup RSLinx as well as how to download from...

    Click here to view the full article at TheAutomationBlog.com
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

  2. #2
    Member FarmerJ's Avatar
    Join Date
    Oct 2019
    Posts
    1
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    0
    Thanks Thanks Received 
    0
    Thanked in
    0 Posts

    What if Channel 0 is set to ascii instead of DF1?

    I'm trying to go online with a customer's PLC 5/40. When I configure my driver in RSLinx Classic and click on auto-configure it times out without negotiating a connection. I'm using a null modem cable with RS232 to USB adapter and have successfully gone online with other PLC 5/40's at this site, so I can only assume that this particular processor was set to ascii instead of the default DF1. This is the first time that I've encountered this issue and I don't know the proper driver configuration to use. Any help would be appreciated. I don't have a saved offline copy of the existing project so I need to upload from the processor and go online to troubleshoot some issues with the conveyor system that it controls. Thanks

  3. #3
    Administrator Shawn Tierney's Avatar
    Join Date
    Sep 2016
    Location
    Berkshires, MA
    Posts
    2,341
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks Thanks Given 
    24
    Thanks Thanks Received 
    6
    Thanked in
    6 Posts
    Good morning @FarmerJ,

    Could be a few different things, including the port isn't set to System (Point-To-Point)

    First thing I would do is open the offline file and check the settings of channel zero, then set RSLinx to match if possible (assuming it's not ASCII)

    If that didn't work, I'd try auto-configure on another PLC-5 just to be sure the cable still works.

    And if the cable still works, but the settings if the offline file don't, I'd try to connect over DH+ to see what the serial port is actually set at (I'm assuming you can't pull the controller to insure the port is set to RS232?)

    Hope this helps,

    Shawn Tierney,
    Instructor at www.TheAutomationSchool.com
    Looking for affordable automation training? If you are, check out my courses at TheAutomationSchool.com!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •